Config rpcbind and rpcallowip,litecoin-cli can not connect local litecoind server


#1

when i start litecoind server in my vm . i can’t connect rpc server in my physical pc. so i config rpcbind my vm ip and rpcallowip my physical pc ip , then i can connect to rpc server from my physical pc. but litecoin-cli is can conenct in my vm .


#2

are you sure that you set rpcbind correctly?
did you set the rpcusername/pass?
that is usually required


#3

rpcuser=test
rpcpassword=test123
rpcallowip=192.168.61.1
rpcbind=192.168.61.129
config like this.
i sure is right ,i can connect from 192.168.61.1 to 192.168.61.129 rpc server


#4

If you are trying to connect to a virtual machine that you are running on the same machine then your using the wrong IP{ address…you need to be using 127.0.0.1 or 0.0.0.0 …
you can only use the 192.168.61.1 address if you are trying to connect to a machine with a separate device through your router

also your rpcbind and rpc allow addresses need to be the same…you have them listed differently… .129 and .1
change both of those to either 127.0.0.1 or both to the address of the machine you are trying to connect WITH not the one your trying to connect TO


#5

Also the options store on litecoin.conf are not used by litecoin-cli (only if you specify a config file) so you’ll need to pass the same parameters to litecoin-cli in order to connect and auth to litecoind