Fixing and hacking KNC Titans and MAT miners because they break from time to time


#62

Quick follow up: Got that unit fixed for seam, problem was in the FETs on one of the power supplies. Probably ran a bit too hot, I like to keep the power supply temps below 80c and the main chip temp under 46c or so. That’s part of the key for long life on these units, slow them down just a little bit.


#63

Hey Lightfoot, I have an issue with my board that I’m pretty sure that you’d be able to help me with. I made an account specifically to get in touch with you, but my account is to new to message anybody. If you are interested please get in touch with me.
Thanks man!


#64

Hi @lightfoot, I’m hoping you can provide me with some assistance with my newly acquired, and newly broken, titan mining setup!

I bought the controller, 3 PSUs and 5 cubes recently and got everything up and running with 4 working cubes - the seller advised me that the 5th cube seemed to kill the controller so I ran the system for a couple of weeks mining at around 110 MH/s. I didn’t want to muck around with the system, trying to coax the cubes to run as efficiently as possible, and get the final cube to play, until I was confident that it all worked.

After around a fortnight, one of the PSUs died - the one that controlled both one cube and the controller board. I didn’t have a spare PSU, so I removed one cube from the system and changed the PSU connected to the controller to another. It was simply one molex off and one molex on - simple…

When I powered on the system again, the magic smoke immediately escaped from my Raspberry Pi. Totally dead.

I have just got hold of a new RPi and this seems to work fine with the old micro SD card. I tried plugging this new Pi into the controller board and powering the Pi (with its integral micro USB B socket) and one cube up, but the controller board’s display doesn’t power up, so I guess I need to power up the controller board with the molex connector to get things running again, but I’m scared! I don’t want to cook another Pi!

What could have caused the Pi to cook? Faulty PSU? Faulty Pi that would have died anyway? Is there way way to power the controller board and Pi separately?

What would you advise?

Once I get the system up and running again, I’ll probably be sending you the board from the troublesome cube!

Thanks in advance.


#65

Morning!

The problem with Pi’s is that their power converters are garbage. When they fail, the Pi shorts the +5 to ground and dies. Normally this is merely annoying, but in a Titan controller the +5 is supplied by a very very big power supply (compared to a usb supply) which burns out a line on the bridgeboard which supplies power to the Pi.

+5 is also used for other things on the Titan board, so you do need to power the +12,+5 line through the molex in any case. If your new Pi boots and runs the old code (newer 1.2b Pi’s will not boot the old code BTW) then you may be able to get the controller running with a back-feed through the Pi USB power and the main molex plug being powered at the same time.

That should get you going. Then take a look at the speeds on your cubes, some dies may just be off due to thermal paste issues.

C


#66

Thanks for getting back to me so promptly - much appreciated.

The new (secondhand) pi seems to be booting successfully using the old micro SD card.

Can I just clarify that you’re suggesting powering both the controller board with the molex and the RPi’s micro-USB port?

Thanks.

M


#67

Maybe. I doubt it would blow up the controller, but I’ve never tried that myself.


#68

Hello guys, pls help me, there is anyone can repair cube?

I am trying to contact lightfoot but i cant find option of write a private message.
Can anyon help me ? Please


#69

Sure, I keep an eye on this thread and can send you a PM. What seems to be wrong?


#70

@lightfoot

my Neptune just went wonkie on me. I tried to do a firmware flash and now my I get the Network link light, and I get a single blue light, but no longer get the pretty disco lights.

I saw you said something about flashing a Debian stock image, but I can’t seem to find it with ye old google.

Any links you can provide? I was using the images from :


http://4thamd.com/KnC/

Thanks!


#71

Well it is a bbb so you can just download debian to an sd card and compile the neptune code by doing a git pull. Not hard.

Titans were harder to do but i already did that.


#72

@lightfoot - I was able to find an install an image. I was doing a 4gb eMMC image, instead of a 2gb. :slight_smile: Hence the issue I was having. I tried to PM you, but I guess since I am new, I don’t have rights too. I am having issues with my neps, and was hoping you could help, or I could have you fix them.

3 days ago, I had 4 of my 5 cubes running just fine. I got a new power supply and just added the 5th, and then everything went down. So pulled new cube off, then none of the old ones work. Right now its just dead in the water. I got the knc firmware back up, but it won’t see any cubes.

I read your thread on bitcointalk, but it seems some of what you were saying is above my pay grade, which is why I wanted to poke you about it, but my account is old and waiting for them to unlock it for me. (day 3 now and still waiting for the unlock).

Thanks Bud.
-RS


#73

Hm. Well, do you have the 2.02 Neptune code, does the display work with no cubes attached, and does the little light on the side of the board come on green, or does it flash a bright white then never come on?

C


#74

I do not have the 2.02 code (and I couldn’t find it anywhere). I do not have a display on my board. The “green” light no longer works on my board… which is why I think its dead. :frowning:


#75

Ok. If the green light used to come on (you had a code > 2.00, early code never lit that light) and this happens when the ribbon cable to the miner is unplugged then the FPGA on the mainboard is most likely bad/shorted. You can verify this by logging in as root, then typing

io-pwr init

And see if errors come up. If they do, the FPGA is out.

Fixing the FPGA is a real job; it’s a 324 pin BGA, the board has to be cleaned, and refloating a new one (about $100 part) is difficult. So it’s expensive to do, and since these boards can and are still being used for Titans (which can make money) fixing them for a Neptune is a bit uneconomical.


#76

Hi lightfoot, big fan of your work! i think it is truly amazing the esoteric work you do!

Im revisiting getting some knc titans working. i got them off ebay and never got them running bc life but now I have more time so trying again. [i tried to message you but couldnt find the button. noob at forums here so excuse me if i do something weird.]

I have 2 knc titan boxes, the 2 - 5 x 2 pin data ribbons, and the 2.00 OS that’s it. I have a RPi of a friend that I could use for testing. I had an SD card but it was full size so i need to order a micro.

before I really get started I need to make a controller board so Im just wondering as of today what would you recommend: BBB or RPi (model/type of each if it matters)?

So do I need to find 5 x 2 pin headers to somehow attach to the tiny computer to transmit data or some other kind of adapter?

If i understand I’ll need: my 2 miners, the 2 data cable ribbons (5x2 pin), power source for miners, micro SD, micro SD computer (BBB or RPi), 2 headers for Titan => OS and associated connectors, and the OS installed?

such thanks and much help you have thanks


#77

Hm. You need to have a Neptune or Titan (or maybe a Jupiter) controller board to plug the BeagleBone into and if you use a Pi you also need the bridgeboard to connect the Pi to the Titan/Neptune controller board. That board has a big FPGA on it that does all the nonce collection and polling for the various Titans, so you have to have it.

Do you have one of those?


#78

I do not. so even despite having a computer to run the OS one would need a special “middleman” with the FPGA to bridge the gap between “brain and muscle” so to speak?

So, those have all been made by Titan and are specific to their devices/manufacturing?

in your reply is controller board the same as bridgeboard? Or you have
Pi <=> bridgeboard <=> controller board
or BBB <=> controller board ?


#79

Exactly. Something needs to do the housekeeping to control the hashing chips, deliver nonces, and pick up and quickly transmit found blocks. That’s the function of the FPGA and pretty much every miner since the Jalapeno has had one on there to handle all the cores.

C


#80

ok, thank you for that explanation. i havent looked in a while so I’ll start looking again online, but in the meantime do you know of any ways to get my missing pieces/have any already?

and to clarify I can use either neptune or titan controller board/bridgeboard? (i’ve seen that written before just want to confirm)

it hurts when you have miners not mining :stuck_out_tongue:

I appreciate your help tremendously. I got on this forum to talk to you!


#81

I do, but the repairs to them are somewhat expensive. Try and find a Neptune controller first, you can then use my free (donate something, I like to eat) code and get your units up and going.

Meantime I’m still fixing miners, people send me all sorts of stuff with burned plugs and the like. Keeps my brain occupied…