Fixing and hacking KNC Titans and MAT miners because they break from time to time


#82

Hi lightfoot, I have a dumb question.
I am a bit embarrased, so can you message me for it?


#83

No really dumb questions out there, but I did message you.


#84

Hello i recently purchased a titan v1 kit and the LCD screen will turn on but won’t display any information, also none of the cubes will register in the program but the fans will power on. Do you have any idea what the problem could be? also the raspberry pi does function and broadcasts to our network through a Ethernet cable.


#85

Controller could be bad. Try unplugging all of the cubes (with the power off) from the controller, then power up just the controller. See if the display comes up, see if the 3 LEDs on the board right under the Rpi come up, see if the white LED on the side board flashes white twice then goes green.

If so the controller is good and you need to plug in the cubes one at a time (always turning power off first). Remember the cables need to be on all 10 pins in the cube, and pin 1 is on the left most side of the cube with pin 1 being closest to the display on the controller.


#86

Okay what i am seeing is that only the first LED comes up solid green the other two do not come up. Also i see a red LED on the Rpi immediately come up while it takes a few seconds for the green LED (first LED) directly underneath it to come up.


#87

Ok, sounds like the FPGA on the controller is dead and the Pi/Bridgeboard is good. Let me know if you would like me to fix it.


#88

Yes that would be great, so how do we go about this? what address do i mail it to and where do you take payment?


#89

Will send you my address in a PM. As for payment, I take Litecoin, the coin with quick transaction times and low fees…


#90

Hey lightfoot, wondering if you have any suggestions for troubleshooting a cube that I can see in the interface, but is not mining?

06 AM


#91

Could be the drivers on the cube if other cubes are working. Have you tried running it at 50mhz on all dies to see if it comes up? If so (it pulls 7a per power supply) it could be a loose heat sink.


#92

Thanks for the speedy Christmas reply!

Just tested it out at 50mhz. Still not hashing. Amps hovering between 0.3 and 1.5 across all dies. What does the process look like for reinstalling the driver on the cube? Is this something you could fix if I sent it to you?


#93

Possibly can fix it. You have to swap out 4 very small drivers, I’m working on one just like yours right now, not an uncommon problem.

C


#94

Hello Lightfoot I am having issues with one of my Antminer L3+. Three out of the four hashboards have disappeared so hence I was wondering if you could help me in someway to get these back up and running?


#95

Hm. I haven’t done much with L3’s yet, have you tried contacting bitmainwarranty to see if they can look at it?

C


#96

I did contact them but having a L3+ machine gone for two month is a big opportunity cost so I was wondering if there would be quicker ways to repairs the hashboards.


#97

They have a two month backlog?

Wow. Well, I can take a look at it and check the obvious issues, but I can’t guarantee a repair. I will not do anything that could be potentially damaging without getting approval. If you want to give that a go send me a PM and I’ll send you a shipping address.


#98

I am having this exact issue have you found out the problem or fix?


#99

I’d be more than happy to check it out if you would like.


#100

Attached is a screenshot of the cube i am having issues with. I was wondering if this is an easy fix something i can do or if it is a more major repair?
Thank you for you time and help.


#101

Two things: First try cutting all frequencies to 50mhz to see if the dies even come up. If they do you might have a heat sink problem. But first try running the first two at 150mhz, if they pull the same current as the 300mhz ones then one supply is out. But you will get a full die out of the deal, not bad.