L3+ solo mining on a home network


#1

Hi, please help? I have been solo mining on a home network on different wallets using different equipment (titans,a4s,ect.) I can’t get the l3+ to solo mine.
do i need install a different miner? I thought bfg miner might do the trick? Or is it a piece of code at the end of the url? I have tried to set up a stratum-proxy and failed. Please help?


#2

Why solo mine?


#3

2.5gh solo mining


#4

try GitHub.com/dmaxl/cgminer pretty sure it has l3 support…I know it has solo support at least


#5

Hi thanks for replying, the l3+ has cgminer


#6

then just set your payout address and point the miner to the ip address you are running your litecoin server on and just make sure that you generated that address with the same ip and it should connect…you may need to type connect (ip) add in console of your miner and set cgminer to -listen
also your gonna need to creat a .conf file containing:
server=1
rpcuser=(LTCaddress mining to)
rpcpassword=x
rpcallowip=(ip of your miner)
rpcport=9333
port=9332
gen=1


#7

Hi, I’m trying to get my L3+ to mine a Scrypt Altcoin. I tried using your suggestion and placed the info you suggested in a new file in my altcoin appdata. Setup is like this:

L3+ is set up as so:
URL: http://(local ip of computer with altcoin wallet):9333
Worker: (address of altcoin receiving address)
Password: X

In the appdata of the coin I am trying to mine I included this altcoin.conf file
server=1
listen=1
daemon=1
rpcuser=(address of altcoin receiving address)
rpcpassword=X
rpcallowip=(local ip of l3+)
rpcport=9333
port=9332
gen=1

Shows up as dead on my L3+ when I try to mine it, any suggestions? What am I missing? I just noticed that you mention to point the l3+ to the ip address of “your litecoin server”, is that the same as having the litecoin qt wallet, or in my case the altcoin qt wallet running?


#8

did you make sure the file has a .conf extension on the end of it? os instead of a batch file you’d have a .conf file…

if your router has DHCP enabled then you more than likely need to add your miner to your router manually by sshing to the ip address of your router…10.0.0.1 for comcast …192.168.1.1 for belkin and then click “add device” and it will ask for the devices ip address and mac address…ip address and MAC address/Device ID should show on your home screen when you ssh to the miner though but I dont have an l3 myself so I am not sure…

if you need the MAC address/Device ID you can get that through command prompt by connecting the miner to your machine and typing ipconfig all in windows and ifconfig in linux/mac

one other thing to make sure of (since you are trying to mine solo) is make sure that your router is allowing incoming connections to your external ip address…that option was under advanced options in a comcast router from what I remember

if the external thing isn’t the issue then you may need a second router internally on your connection if you cant accept outside connections like web servers can (some internet providers wont allow this) but if you hook up a cheaply secondary router and disable DHCP on it then you can guarantee that it will route thew connection to the machine your running your wallet on

try adding it manually to your router first though


#9

Also…you need to delete daemon=1 as the litecoind daemon is not used anymore…

you need the user name and password in the .conf file also so it looks like you need to add that and delete daemon

How are you starting the server when you start it?
with the newest version of litecoin in windows command prompt you’ll want to start litecoin-qt like this: After you “cd” to the location of litecoin-qt installation…type: litecoin-qt.exe -server -disablewallet -addnode (static ip address of your litecoin-qt server machine)

make sure you have a static ip set for the machine you are running your server(wallet disabled for mining)

fist open a command prompt by clicking cortanta and typing “cmd”…once the command prompt opens…type: ipconfig
Now minimize that window

go to “network and internet connections”, click “change adapter options” then select the connection you are using with a single click to highlight it…
Then at the top click “change settings of this connection”

once that pops up double click “Internet Protocol Version 4 IPV4”

now pick any number between 50 and 254 and asign that to your machine…
example…if using belkin 192.168.1.254
now set your subnet mask

Go back to your command prompt window and copy and paste the subnet mask or just manually copy it
then type in your gateway…(should be the ip address of your router)
set your DNS to 8.8.8.8 and 8.8.4.4 for google or 75.75.75.75 ans 75.75.76.76 for comcast

now you will need to manually add your machine to your router using the new static ip address you just made and the MAC address listed oon the command prompt window for the device you are running your server on…

once you have manually added your static ips and device ids/MAC address for your Server and miner to your router and your .conf file has matching information…you should be able to start litecoin-qt from command prompt and then start your miner

One more thing you can do is download bfgminer and point bfgminer to your wallet and then your miner to bfgminer and it will show up as a Proxy worker…This is just another option and I would not try this unless you cant get it working the other way first…proxy servers can be really tricky


#10

Well I’d tried working through your suggestions, and I did get further ahead, but it is still showing as dead.

When I log into my router, and check the dhcp client table, both the l3+ and computer I am wanting to use as a server show up there. The ip’s of both of them havent changed in days/weeks, so I’m not sure if I need to set them as static ip’s…if you think that is necessary, I will work on that for a while tomorrow and see if that doesn’t solve the problem.

Initially, I did have the .conf wrong, because I failed to set the save as to all files, so it was saving it as .conf.txt which of course won’t work.

When I first tried starting the wallet with -server, windows wouldn’t allow it claiming that I needed a stronger password (I only had the X), so Windows gave me a big string to use as password, and I inputted that into the .conf file and also the l3+ password area. rpcuser and rpcpassword are the user and password sections in the .conf file.

You mention to “one other thing to make sure of (since you are trying to mine solo) is make sure that your router is allowing incoming connections to your external ip address” not sure on the reasoning behind this as both the l3+ and computer I am using to mine on are on the same home network. 192.168.1.136 (miner) and 192.168.1.138 (computer/server).

When I did run netsat -a | find “LISTENING” on the computer/server it did show the 0.0.0.0:9333 and 192.168.1.138:139 as being listened to…although it did not show any sign of the 192.168.1.136 (miner local ip) as being listened to…perhaps this would be resolved if I set them both up as static ip addresses?

I was able to start the altcoin qt with altcoin-qt.exe -server -disablewallet -addnode 192.168.1.138 without any problems other than the miner showing that ip as dead ie not mining


#11

Hi I have always been able to solo mine before, there is nothing wrong with my config. It is something abot l3 miner stopping it. The one solution is a a stratum proxy on a spare pc


#12

Create a receiving address in the wallet and make sure the wallet is synced…this will use DNS to register that address to your external ip address…
now… there should be a solo configuration on the l3 but if not then you’ll have to set it up as a proxy…if there is a solo configuration on the l3 then you don’t need to run the wallet on a separate machine and just need to set the l3 pointing to your wallet address instead of an ip address…
then when you run you wallet on the separate machine…DNS will connect to the ip address of the receiving address

I do know that you will need to set your miner to -listen somehow…when using cgminer I know you can use the -listen flag so running bfgminer as a proxy server should do the trick if there is no way to set the l3 to listen in the gui that you ssh to on the l3…this is usually how a pool is configured though

mining solo with a miner that is connected using Ethernet is either a proxy connection or a longpolling connection that setup like a “personal pool” or the miner will have a solo configuration on its GUI…so…

if there is no solo configuration on the miner
try using bfgminer as a proxy server and pointing that to your wallet server and then pointing the l3 at bfgminer…you would have to run bfgminer on a separate device or you will need dhcp on your machine that is running both altcoin and the proxy server at the same time…

with dchp on your machine that is running the wallet and bfgminer it should give the first server that connects the address of 127.0.0.1 and the second one as 127.0.1.1 or 127.0.0.2

if it is running on 0.0.0.0:93333 you do need to set it to 127.0.0.1 in order for local intranet address(programs running on the same machine) to be able to connect to it…probably need it that way for local network connections to longpolling / proxy as well…


#13

sorry for the edits but anyway I do know that every-time you click the “Request payment button” and your wallet creates a new address that DNS registers that address with the external ip address…this is why I said you need to make sure your router is allowing incoming connections to the external ip…

otherwise you have to set it up like a personal pool using a proxy server for the node that is running the solo miner


#14

Thanks for your response, I have tried different stratum proxy software. I can get it running, it is the configuration I cannot get my head around enough to get it working. I have solo mined before direct to many different wallets using orher equipment, these l3’s are stubborn :thinking:


#15

its because your miner’s software has no solo configuration…like bfgminer does

if you download bfgminer and run it as solo and then point your miner towards bfgminer as a proxy it will work…

if your mining software does not support solo then this may be your only option

stratum software isn’t setup for solo mining…but bfgminer is…stratum is used for pools and accepts connections to the exterior ip address…you are trying to mine locally…which is why stratum software wont work for you

are you sure your running the script right?..you do know that for solo you cant point the miner to an ip address right? you have to point the miner towards the “coinbase payout address” and this is true for all solo mining configurations

the command is -o (receiving Litecoin address you are mining to) (then arguments such as chip options and so on)

if you point a miner towards an ip address that is pool mining whether you setup your own personal pool or connect to one externally…

here is how bfgminer sets up solo configurations: https://gist.github.com/luke-jr/7539234
and here is bfgminer: https://github.com/luke-jr/bfgminer

look like to me here that you best bet is to run bfgminer with a solo configuration and make sure you start it using command prompt with the -http-port 3333 flag…this will make bfgminer your proxy server for your wallet…then point your miner at the static ip of the device you are running bfgminer on

so the command would be bfgminer.exe -scrypt -o http://(static ip of the machine running bfgminer:9333) -http-port 3333

do not set chip counts or devices in bfgminer
then ssh to your miner and point it at bfgminer at the same static ip pointing it at 3333

you cannot use the same port to call out as you do to listen


#16

here’s an example I know works every time…say I have a litecoin wallet on my desktop here and I want o mine solo to it using a miner that has an Ethernet connection going to it and a GUI on that controller…(such as your l3)
like I said the starting scripts for solo and pool mining configurations are different…

from command prompt in windows (for linux change .exe to ./ before program name)
I start my wallet…litecoin.exe --server --addnode 192.168.1.110
then I start bfgminer from the same machine like this:
bfgminer.exe --scrypt -coinbase-addr (litecoinaddress) -http-port 3333
now say I set my static ip for the machine that is running both of these programs to 192.168.1.110
I ssh to the miner and point the miner using http not stratum because stratum is not used for local connections to :
-scrypt http://192.168.1.110:3333 -u (user name in your config file) -p (password in the config file) (chips count and frequency options)
done


#17

hope you got my last edited reply as it should get you mining solo rather quickly if you do it step for step


#18

Ok, I understand the other instructions, but I’m not sure about the above instructions related to bfgminer.exe, as I used primarily cgminer a few years ago, and am now using the L3+.

“bfgminer.exe --scrypt” I get
"-coinbase-addr (litecoinaddress)" not sure about, do I need to actually use “-coinbase-addr (my altcoin address)”
"-http-port 3333" is that the actual command? or am I to put an ip address in there somewhere? And if that is the port, what am I using in the conf file of the altcoin I’m wanting to mine rpcport=3334
port=3333?

Thanks


#19

you can use cgminer the same way…
you can use any pot you want your proxy server to listen on (except 9333 because you are listening to your wallet using that port) as long as it is no 443 or 80 along with a few others that are low numbers and used for things like email servers and such…most pool choose 3333 so that’s why I chose that

…litecoin listens on 9333 to the network so you just need a different port for your miner to connect to the node…
http-port is the command for bfgminer…
cgminer users has a -listen flag…

start cgminer with --help flag to get the options for it…I recommend bfgminer because it does proxy…I dont think cgminer will do that but it does have a -listen flag option

here is the command for solo cgminer using dmaxl version:

cgminer.exe --scrypt -btc-address (litecoinaddress) --listen 3333
bfgminer supports solo and not all cgminer versions have a solo option…I know dmaxl’s version of cgminer does solo…

make sure the version of cgminer you are using has solo support

then ssh to your miner and point it at the static ip that is running cgminer

one more thing…make sure your .conf file matches the settings you are using…keep api-port at 9333 for litecoin and since we used 3333 above then make sure you have port -3333 in there…should look like this:
server=1
rpcallowip=127.0.0.1
rpcport=9333
port=3333
gen=1

one more thing delete rpc user and password so it looks like above…unless you are using vpn or a stats web page this is not needed and make sure that your .conf file is saved as litecoin.conf …otherwise you have to specify thename of the .conf file with the -conf flag when starting form command prompt
then start the wallet with flags to: -server and -add-node (static-ip of machine running wallet)

form command prompt start litecoin-qt.exe --help and cgminer.exe --help and make sure you are using all your options correctly


#20

remember that you will not see and “accepted shares” when mining solo…
you will only get a result if you find a block…as long as you see the stats at the top of cgminer/bfgminer showing connected and hashing with the current difficulty of 1.2 million then you are solo mining