Litecoin compilation guide


#1

I’d like to ask a pressing question about Litecoin compilation? The information contained in the Litecoin Wiki is obsolete. I’d like to compile Litecoin by myself, but I don’t have enough a skill. Thankful in advance for the answers and any help.


#2

Could you be a bit more specific, by indicating which OS you are planning to use ? Linux is the easiest environment, followed by OS X, and finally Windows is the worse of them all. If you are stuck with Windows, due to your limited technical skills, I wouldn’t even try it. Worse case, you could install a Linux VM on your PC and compile Litecoin-qt on it.


#3

If you are on Linux Ubuntu 16.04, follow those steps (cut and paste one line at a time in a new Terminal window):

**** ensure that the system is up to date ****
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get autoremove
sudo reboot

**** download the source code ****
mkdir Github && cd Github
sudo apt-get install git
git clone https://github.com/litecoin-project/litecoin
cd litecoin

**** Install the dependencies ****
sudo apt-get install build-essential libtool autotools-dev automake pkg-config libssl-dev libevent-dev
sudo apt-get install bsdmainutils libboost-system-dev libboost-filesystem-dev libboost-chrono-dev
sudo apt-get install libboost-program-options-dev libboost-test-dev libboost-thread-dev
sudo apt-get install libqt5gui5 libqt5core5a libqt5dbus5 qttools5-dev qttools5-dev-tools libprotobuf-dev
sudo apt-get install libqrencode-dev protobuf-compiler miniupnpc

**** To install the deprecated version of Berkeley DB 4.8 ****
sudo add-apt-repository ppa:bitcoin/bitcoin
sudo apt-get update
sudo apt-get install libdb4.8-dev libdb4.8+±dev

**** Compile ****
./autogen.sh
./configure
make

**** Optional *****
sudo make install

**** Execute ****
cd ~/Github/litecoin/src/qt
./litecoin-qt


#4

The above steps will give you the branch with the latest accepted pull requests: 0.13.99 - if you want 0.13.3, after cloning the GitHub repo, do “git checkout 0.13” then compile.

Similarly, if you want the 0.14-dev branch, do “git checkout 0.14-dev”, then compile

If you want to save some compiling time, and don’t want the testnet binaries, do “./configure --disable-tests --disable-bench”, then “make”


#5

Thank you, guys! But I want to compile Windows wallet 0.14-dev on Ubuntu 17.04 Is it possibe? If yes which steps I need to do? Thanks in advance again.


#6

i made the compilation without any trouble, but i made some changes and it is giving me an error un ubuntu,
but i cant find the debug.log file, so i cannot fix it, the file is supposed to be created in home/user/.litecoind, it does nt create the .litecoin folder, working on ubuntu 16.04, any help


#7

The .litecoin directory is hidden by default. You have to go the files browser and select the View menu, and then Show Hidden Files, when on Home directory.


#8

thanks for the reply, but before posting i checked the directory and search for the hidden files, but the folder was not created, and i looked everywhere, not just where it was supposed to be