Ugh, rejection is hard to deal with


#1

Hello there techies. I have been doing all kind of reading and checking on how to fix this issue, to no avail so I thought I would put this out there to see if I could enlist a bit of help. It seems my miner (ccminer) keeps getting a lot of rejection. I have let it go for hours with no change. It must be in my script syntax, but im just not well enough versed to figure it out… I have tried umteen versions of CCMiner and guiminer etc, still no joy. Any techie want to throw me a bone? Thanks guys.

My syntax is:
ccminer.exe -t 1 -a scrypt --url=stratum+tcp://prohashing.com:3333 --userpass=XXXXXXX:XXXXXXXXX (credentials hidden)
which nets the below:

*** ccminer 1.8.3 for nVidia GPUs by [email protected] ***
Built with VC++ 2013 and nVidia CUDA SDK 7.5

Originally based on Christian Buchner and Christian H. project
Include some of the work of djm34, sp, tsiv and klausT.

BTC donation address: 1AJdfCpLWPNoAMDfHF1wD5y8VgKSSTHxPo (tpruvot)

[2017-06-14 14:04:50] Starting on stratum+tcp://prohashing.com:3333
[2017-06-14 14:04:50] NVML GPU monitoring enabled.
[2017-06-14 14:04:50] NVAPI GPU monitoring enabled.
[2017-06-14 14:04:50] 1 miner thread started, using ‘scrypt’ algorithm.
[2017-06-14 14:04:50] Stratum difficulty set to 16384 (0.25000)
[2017-06-14 14:04:50] scrypt block 95251, diff 112907.851
[2017-06-14 14:04:54] GPU #0: 32 hashes / 4.0 MB per warp.
[2017-06-14 14:04:54] GPU #0: Performing auto-tuning, please wait 2 minutes…
[2017-06-14 14:04:55] GPU #0: maximum total warps (BxW): 1491
[2017-06-14 14:06:12] GPU #0: 541735.25 hash/s with configuration T54x4
[2017-06-14 14:06:12] GPU #0: using launch configuration T54x4
[2017-06-14 14:06:13] GPU #0: Intensity set to 12.6875, 6912 cuda threads
[2017-06-14 14:06:13] scrypt factor set to 9 (1024)
[2017-06-14 14:06:16] GPU #0: EVGA GTX 1080, 192.99 kH/s
[2017-06-14 14:07:12] GPU #0: EVGA GTX 1080, 207.07 kH/s
[2017-06-14 14:08:13] GPU #0: EVGA GTX 1080, 206.57 kH/s
[2017-06-14 14:09:44] GPU #0: EVGA GTX 1080, 137.27 kH/s
[2017-06-14 14:10:24] GPU #0: EVGA GTX 1080, 204.74 kH/s
[2017-06-14 14:10:26] scrypt block 95252, diff 97242.325
[2017-06-14 14:11:27] GPU #0: EVGA GTX 1080, 202.99 kH/s
[2017-06-14 14:12:26] GPU #0: EVGA GTX 1080, 206.53 kH/s
[2017-06-14 14:13:27] GPU #0: EVGA GTX 1080, 206.20 kH/s
[2017-06-14 14:14:27] GPU #0: EVGA GTX 1080, 206.36 kH/s
[2017-06-14 14:15:28] GPU #0: EVGA GTX 1080, 206.43 kH/s
[2017-06-14 14:16:27] GPU #0: EVGA GTX 1080, 209.57 kH/s
[2017-06-14 14:17:27] GPU #0: EVGA GTX 1080, 209.15 kH/s
[2017-06-14 14:17:52] scrypt block 1693542, diff 8312.048
[2017-06-14 14:18:15] scrypt block 1693543, diff 8491.774
[2017-06-14 14:18:17] scrypt block 1693544, diff 9331.083
[2017-06-14 14:18:17] scrypt block 95252, diff 97242.325
[2017-06-14 14:19:17] GPU #0: EVGA GTX 1080, 209.42 kH/s
[2017-06-14 14:20:19] GPU #0: EVGA GTX 1080, 202.23 kH/s
[2017-06-14 14:21:18] GPU #0: EVGA GTX 1080, 208.96 kH/s
[2017-06-14 14:22:19] GPU #0: EVGA GTX 1080, 206.43 kH/s
[2017-06-14 14:23:19] GPU #0: EVGA GTX 1080, 209.97 kH/s
[2017-06-14 14:23:23] scrypt block 95253, diff 97242.325
[2017-06-14 14:24:00] scrypt block 95254, diff 33489.296
[2017-06-14 14:25:04] GPU #0: EVGA GTX 1080, 195.21 kH/s
[2017-06-14 14:25:18] scrypt block 95255, diff 39745.896
[2017-06-14 14:26:03] scrypt block 95256, diff 43359.196
[2017-06-14 14:26:43] scrypt block 95257, diff 50352.909
[2017-06-14 14:27:40] GPU #0: EVGA GTX 1080, 207.17 kH/s
[2017-06-14 14:27:46] scrypt block 95258, diff 59110.389
[2017-06-14 14:28:45] GPU #0: EVGA GTX 1080, 210.05 kH/s
[2017-06-14 14:29:45] GPU #0: EVGA GTX 1080, 209.77 kH/s
[2017-06-14 14:30:47] GPU #0: EVGA GTX 1080, 206.30 kH/s
[2017-06-14 14:31:47] GPU #0: EVGA GTX 1080, 209.74 kH/s

any ideas? Thanks.


#2

double check that you have the miner with matching development architecture though like I use that miner and it came with CUDA 8.0 which is the same one I had to download to my machine to get optimal hashing results…it works like crap if you use 7.5 and need 8.0 or use 6.5 and need 7 or something like that…
I don’t see a single rejected share in that…looks lke its mining just fine to me…try connecting to litecoinpool.org as they have live time stats…for the most part anyway…then you can compare their results with how your miner is running…the ccminer you are using is the best one for NVidia…


#3

bakd247,

I kept mucking around with the .bat syntax and was actually able to get it to work (one I changed pools.) for whatever reason, it didnt like prohashing info. I switched pools and it started working… but after a while, slowed way down to about 20% of its original hashrate… really appreciate your reply man, thank you!!!.


#4

no problem…try setting the difficulty higher…like on liketcoinpool.org you can put ,d=1024 or ,d=2048 after your password…sometimes I have to do that in order to get my max rate and then I reset to regular after an hour or so so the server has enough time to calculate the variable difficulty…


#5

So does the d=2048 go after the miners password? Im assuming yes, but for the last week been getting my butt kicked with “assumptions”.


#6

yes it goes after the password so if your password is x then you’d type p x,d=2048 in the batch file…you can also just start the miner in command prompt using the same options…don’t have to use a batch file if you don’t want to…but its recommended for remembering past inputs for troubleshooting and such…
it makes you send and receive packet with 2048 bits of data in them…so you send shares back and forth to the pool larger…if you set it to 128 you turn in 128 shares every second…1024 = 1024 shares per second and so on…if your internet connection is 1 gigabit…that is 30 megabytes per second…because there are 8 bits in one byte…so anything over 2048 would cause connection issues in that instance…
you can also use the proxy server to use cache from your hard drive to increase your share inputs I do this sometime by running the proxy on my gaming rig suing my 6gb/s ssd for cache and then connect my miners locally to the rigs ip address…sometimes its faster to not use the proxy though…really all depends on how many people are connected to the pool and how many routes your connection has to make before it reaches it s final destination or the server your requesting…
another thing you can try is to increase your scan time in cgminer…I think while its running you hit s for settings then set the scan time to less as the default is 60 I think…sometimes when I set that lower my hash rate sky rockets…so once you get the work it all depends on how fast your miner is for finding the perfect scan time though…this basically reduces stale shares I think though